Java version 1.7 required to Google Plugin on Eclipse

This is not related with iOS development but I have deployed the backend service for my iOS app on Google App Engine. This is about the steps for resolving the “JRE version is 1.6.0 1.7.0 or later is needed to run Google Plugin for Eclipse”.


1. Download the latest JDK from oracle website –

2. For some reason the JDK installation folder on Mac was still referring to Java 1.6 and had to install this fix to get 1.7 folder –


3. Then install the latest Google App Engine eclipse plugin using the Check for Updates on Eclipse.

4. I am not 100% sure whether app engine SDK needs to be installed on Mac even after installing eclipse plugin but I went with this step. Download latest app engine SDK for mac

5. The most important step of all is to edit eclipse.ini file and add -vm param with jdk 1.7 (marked in bold). Make sure this entry is the first vm entry in eclipse.ini file.




























3 responses to “Java version 1.7 required to Google Plugin on Eclipse”

  1. hi , i stiil have the error above and I’m unable to create a project

    i have airbook os x 10.9.5

    please help

  2. Excellent advice. Was missing the vm parameters.

    Thanks for your post.

  3. @claud if you are unable to create a project because you don’t see it in the Eclipse its because you are missing Java 7 you can follow this post that I think should be able to help you. Also, once you sintall java 7 make sure you add GAE from the Eclipse marketplace.

    hope that helps.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.